エントリー

昨日からずっとInternet Explorer対処に明け暮れた挙句・・・
殆どあきらめモードに入りつつあります。

いい加減世界の標準に追従してくれよ!!

何のことかというと。
天下のマイクロソフトのブラウザ「Internet Explorer(以下IE)」だけ表示できない!という問題対処です。
firefoxでもsafariでもoperaでもChromeでも問題なく表示されるのに、クソIEだけ認識してくれなくて・・・

まずうちのサイトがW3Cの「XHTML 1.0 Strict」という標準化に厳格なつくりにしていることと、IE独自要素(たしか)の

と思いきや。
肝心のIEで確認してみると"ただの文字列"にしか見えない。
どうやらIEだけは<object width="300" height="150">要素をちゃんと動かしてくれないようです。

そこから色々やってみました。
「もしブラウザがIEだったら<iframe width="300" height="150">で、そうじゃなければ<object>で・・・」なんてコードをどこかから持ってきていじくったりして、なんとかかんとかW3Cチェックではクリアできたけれど、html構文チェックでは40点も減点。

で、結局amazonの定型表示と<object width="300" height="150">要素をどうこうすることは諦め、
小粋空間: Amazon アソシエイト作成支援ツール一覧(http://www.koikikukan.com/archives/2006/03/04-025016.php)で1番に紹介されている「amazletツール」を活用させていただき、少し構文修正をかけることでやっと99点まで持ってくることができました。

ところが、もう一つやりたかったことに対する問題が残ってまして。
YouTube動画をページに貼り付けること。

実はこれもまた<object width="300" height="150">要素でして。
またこれもエラーが色々出てきたのを小粋空間さんのページで助けてもらいました。

小粋空間: YouTube の Embed タグを XHTML valid にする(http://www.koikikukan.com/archives/2007/01/05-003003.php)
しかし、このページにはかなり助けられてます。感謝です。

で、エラーはなくなってすっきりいけたかに思ったのですが、やっぱり最後まで問題が残ったのはInternet Explorer。
ちゃんと表示してくれない・・・
ほんと、他のブラウザはいけてるのに、これだけは。

もう、調べるのも疲れました。
誰かいい方法している方教えてください!

ということで、またIEが嫌いになりましたね。

ページ移動

他にもこんな記事があります


トラックバック

  • トラックバックはまだありません。

トラックバックURL

https://blog.spadive.com/trackback/222

コメント

  • コメントはまだありません。

コメント登録

  • コメントを入力してください。
登録フォーム
名前
メールアドレス
URL
コメント
閲覧制限
「南紀」のよみは?ひらがな3文字で(スパム対策)


正当なHTMLです! 正当なCSSです!

ユーティリティ

archive/過去ログ

No Data
ブックマークはありません。

page

  • ページが登録されていません。
052018/0607
S M T W T F S
- - - - - 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30