インフォメーション

エントリー

タグ「freo」の検索結果は以下のとおりです。

iphone01自分の店のサイト表示は、スマートフォンはiPhoneに、タブレットはiPadに、一応最適化表示対策しています。

 Android他の端末は持ってないし、触る機会が殆ど無いので全くチェックできてないんですが、どうやらドコモ版スマホで表示崩れというか動作不良(?)状態になってるらしい… 

ブログの方はプログラム的にうまく対処されてるものを使ってて、おそらく問題ないと思うんだけど、メインのページはCSSによる簡易調整式で、見た目とJavaScriptが切り替わるようにしてます。 

たぶんその辺の加減のズレで、JavaScriptが思ったとおりの動作範囲で動いてくれなくなり、メインのページがドコモの(その他も?)Androidのスマホでおかしくなってるんだと思います。 

少し前までは一応それなりにちゃんと見れてたそうなので、たぶんこないだ「iPadを購入して表示確認した際に初めて気付いたiPad向け表示崩れ」、に微調整を加えた際におかしくなったような気がする…

20120626172210.jpg

ハズです(^^♪
Feedburnerへは既に画像付きで飛んでるので、あとはgoogleReader等のRSSリーダーやRSS Graffitiでどう表示されるか!?ですが、ちょっとドキドキです。

ちなみに、画像は確認用に適当に撮った、店に飾ってる愛用ギターの一つです。
この記事とは全く関係ありません..

実はここ数日、この画像付き「RSS/Feedにしたい!」という願望達成に向けて、色々試行錯誤しながらも全くうまくいかなくてず~っと悩んでました。

この悩みを完全(?)解消させてくれたのが、ちょうど昨夕アップされていたこの記事です。

「freoのRSSをカスタマイズ - Web Liberty&freoカスタマイズ集」

20120610215631.jpg

Twitterへ飛ばしてもらうのに利用しているFeedBurnerが、それ自体が配信Feedのアドレスがあったのを思い出した。

で、RSS Graffitiにはこのブログの直接配信feedで受ける形ではなく、FeedBurner経由で受ける形にしてみた。

上手くいくかのテスト!

freo.jpというPHPベースの便利なブログツールを利用させてもらってるんですが、いま二つほど困りごとで頭を悩ませてます。

二つともたぶんTinyMce絡みのような気がするんですが…

一つ目は、

添付ファイル画像をスライドショーさせる機能があって、これがW3CのValidationチェックでエラーになる

エラー内容は

「Bad value slideshow for attribute rel on element a: Keyword slideshow is not registered.」

最近気付いて対処に困ってますwww

色々検討てみたけれど、結局これに収まりました。

なんか無駄に(?)遠回りしたけど、一番単純な形に収まった感じです。

iflameでembedってのを入れるとちゃんとiphoneでも表示されることにやっと気づき...

また覚えがきでも一つ。

googleの「iframe 埋め込み式 YouTube Player 向け JavaScript Player API」てのを使ってみた

参考にした記事はコレ。

iframe 埋め込み式 YouTube Player 向け JavaScript Player API のご紹介

そのま~んま。そのまんま設置してdiv内へのタイトル入力とvideoID入力しただけでやってみました。

YOUTUBE動画-20110825南紀白浜 権現崎

よそ様の動画を2つほど貼りつけてみたけど、iphoneではうまくいかなかった。最後に自分の動画で。

ちょっと今更感ありですが、数日前からブログを今の形変えました。

 変えたといっても、アドレスも同じだしデータ引継ぎもほぼ上手くいったので中身も同じです。変わったのは若干の見た目に加えて操作感あたりが変わっただけです。が、完全に変わったことが一つあって、それが冒頭インフォメーションにもあるRSSフィードのアドレスです。

あまりいないかもですが、feedリーダーに登録してうちの記事を読んで下さってる方いましたら登録を変更願いますm(__)m

 ブログツールは
先代CGI版のWeb Diary Proから、同じ作者様のPHPツールfreo.jpへ移行

ほぼ満足な出来上がりになりました。作者のないとさんには大感謝です。

昨日ためしてみたyoutube動画埋込みですが、PC表示は問題なかったけど、iphoneからはやっぱり何も表示されない..

ググッてみたらいくつか手段があるみたいなので試してみる。

まずは、freoの作者さんの記事

freoのentry(またはpage)でYouTube動画をcolorboxで表示する場合

よりメモ目的で引用

tiny_mceで動作がおかしかった点

ボタンクリックで立ち上がった別windowがのっぺらぼうで操作不能

設置後すぐに投稿確認くらいしとけばよかったのに、今になって投稿画面に不具合があることがわかってΣ(゚Д゚;≡;゚д゚)とか、なんとも情けないw

ダウンロード初期状態のfreoをローカル環境に再度セットアップして動かしてみたらちゃんと動作したので、やっぱり何か変えてしまったのだろう..ということで、投稿画面用のhtmlテンプレートやphpファイルを初期状態のものに上書きしたりしてみたが、やっぱりその程度じゃ駄目だった。

で、また投稿画面を操作しながらボタン操作をしていたら、ボタン動作はjavascript動作だということに今更ながら気づき、スクリプトの格納ディレクトリ「tiny_mce」をごっそり入れ替えてみたら\(^o^)/

ページ移動

  • 前のページ
  • 次のページ
  • ページ
  • 1

ユーティリティ

archive/過去ログ

No Data
ブックマークはありません。

page

  • ページが登録されていません。
082017/0910
S M T W T F S
- - - - - 1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30